Email Issue

Email Email
20 hours, 10 minutes

Activity

Resolved
We have been monitoring this issue for nearly 24 hours now and we can safely say that it is now resolved.
Nov 9th, 2018 17:54 GMT
Monitoring
We recently noticed an issue where emails were not being delivered to mailboxes. We have attempted to remedy the situation now but are continually monitoring it just to make sure. We appologise for any inconvenience caused. We believe this issue may have been related to the recent server upgrade.
Nov 8th, 2018 21:44 GMT